package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(man)|[^0-9]`)
var str = `012345m67890man`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}