#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=^\{)(.*?)(\d*?)(?=\}$)"
Local $sString = "// Good names with ids" & @CRLF & _
"{Slitter10}" & @CRLF & _
"{Slitter 10}" & @CRLF & _
"{Slitter 10}" & @CRLF & _
"{Back score 22}" & @CRLF & _
"{Back-score 22}" & @CRLF & _
"{{Back-score}22}" & @CRLF & _
"" & @CRLF & _
"// Good names no id" & @CRLF & _
"{Reference}" & @CRLF & _
"{Back-score}" & @CRLF & _
"{{Back-score}}" & @CRLF & _
"{{Back-score22}}" & @CRLF & _
"" & @CRLF & _
"// Bad names" & @CRLF & _
"{Slitter10}Test" & @CRLF & _
"Test{Slitter10}" & @CRLF & _
"Test{Slitter10}Test" & @CRLF & _
"{Slitter10" & @CRLF & _
"Slitter10}" & @CRLF & _
"Slitter10" & @CRLF & _
"Slitter 10" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")