using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^\{)(.*?)(\d*?)(?=\}$)";
string input = @"// Good names with ids
{Slitter10}
{Slitter 10}
{Slitter 10}
{Back score 22}
{Back-score 22}
{{Back-score}22}
// Good names no id
{Reference}
{Back-score}
{{Back-score}}
{{Back-score22}}
// Bad names
{Slitter10}Test
Test{Slitter10}
Test{Slitter10}Test
{Slitter10
Slitter10}
Slitter10
Slitter 10
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}