import re
regex = re.compile(r"(?<=^\{)(.*?)(\d*?)(?=\}$)", flags=re.MULTILINE)
test_str = ("// Good names with ids\n"
"{Slitter10}\n"
"{Slitter 10}\n"
"{Slitter 10}\n"
"{Back score 22}\n"
"{Back-score 22}\n"
"{{Back-score}22}\n\n"
"// Good names no id\n"
"{Reference}\n"
"{Back-score}\n"
"{{Back-score}}\n"
"{{Back-score22}}\n\n"
"// Bad names\n"
"{Slitter10}Test\n"
"Test{Slitter10}\n"
"Test{Slitter10}Test\n"
"{Slitter10\n"
"Slitter10}\n"
"Slitter10\n"
"Slitter 10\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")