import Foundation
let pattern = #"(?<=^\{)(.*?)(\d*?)(?=\}$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
// Good names with ids
{Slitter10}
{Slitter 10}
{Slitter 10}
{Back score 22}
{Back-score 22}
{{Back-score}22}
// Good names no id
{Reference}
{Back-score}
{{Back-score}}
{{Back-score22}}
// Bad names
{Slitter10}Test
Test{Slitter10}
Test{Slitter10}Test
{Slitter10
Slitter10}
Slitter10
Slitter 10
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)