#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)SomeText#(?:(.*?BACKUP) )?(?P<jobFileList>(?(1)[^ ]*|.*$))"
Local $sString = "SomeText#"C:\\","Shadow Copy Components:\\","E:\\",""" & @CRLF & _
"SomeText#"D:\\"" & @CRLF & _
"SomeText#"E:\\","Shadow Copy Components:\\"" & @CRLF & _
"SomeText#"SET SNAP_ID=serv.a.x.com_1380312019","BACKUP H:\\ USING \\\\?\\GLOBALROOT\\Device\\HarddiskVolumeShadowCopy47\\OPTIONS:ALT_PATH_PREFIX=c:\\VERITAS\\NetBackup\\temp\\_vrts_frzn_img_3200\"" & @CRLF & _
"SomeText#"SET SNAP_ID=serv.a.x.com_1380312019","BACKUP Y:\\Libs USING \\\\?\\GLOBALROOT\\Device\\HarddiskVolumeShadowCopy47\\OPTIONS:ALT_PATH_PREFIX=c:\\VERITAS\\NetBackup\\temp\\_vrts_frzn_img_3200\"" & @CRLF & _
"SomeText#/ahol5d72_1_2" & @CRLF & _
"SomeText#/p7ol4a1p_1_2" & @CRLF & _
"SomeText#Gvadag04SANDsk_Daily" & @CRLF & _
"SomeText#/bck_reco_a9ol5765_1_2_827497669"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")