import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "SomeText#(?:(.*?BACKUP) )?(?P<jobFileList>(?(1)[^ ]*|.*$))";
final String string = "SomeText#\"C:\\\\\",\"Shadow Copy Components:\\\\\",\"E:\\\\\",\"\"\n"
+ "SomeText#\"D:\\\\\"\n"
+ "SomeText#\"E:\\\\\",\"Shadow Copy Components:\\\\\"\n"
+ "SomeText#\"SET SNAP_ID=serv.a.x.com_1380312019\",\"BACKUP H:\\\\ USING \\\\\\\\?\\\\GLOBALROOT\\\\Device\\\\HarddiskVolumeShadowCopy47\\\\OPTIONS:ALT_PATH_PREFIX=c:\\\\VERITAS\\\\NetBackup\\\\temp\\\\_vrts_frzn_img_3200\\\"\n"
+ "SomeText#\"SET SNAP_ID=serv.a.x.com_1380312019\",\"BACKUP Y:\\\\Libs USING \\\\\\\\?\\\\GLOBALROOT\\\\Device\\\\HarddiskVolumeShadowCopy47\\\\OPTIONS:ALT_PATH_PREFIX=c:\\\\VERITAS\\\\NetBackup\\\\temp\\\\_vrts_frzn_img_3200\\\"\n"
+ "SomeText#/ahol5d72_1_2\n"
+ "SomeText#/p7ol4a1p_1_2\n"
+ "SomeText#Gvadag04SANDsk_Daily\n"
+ "SomeText#/bck_reco_a9ol5765_1_2_827497669";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}