use strict;
my $str = 'SomeText#"C:\\\\","Shadow Copy Components:\\\\","E:\\\\",""
SomeText#"D:\\\\"
SomeText#"E:\\\\","Shadow Copy Components:\\\\"
SomeText#"SET SNAP_ID=serv.a.x.com_1380312019","BACKUP H:\\\\ USING \\\\\\\\?\\\\GLOBALROOT\\\\Device\\\\HarddiskVolumeShadowCopy47\\\\OPTIONS:ALT_PATH_PREFIX=c:\\\\VERITAS\\\\NetBackup\\\\temp\\\\_vrts_frzn_img_3200\\"
SomeText#"SET SNAP_ID=serv.a.x.com_1380312019","BACKUP Y:\\\\Libs USING \\\\\\\\?\\\\GLOBALROOT\\\\Device\\\\HarddiskVolumeShadowCopy47\\\\OPTIONS:ALT_PATH_PREFIX=c:\\\\VERITAS\\\\NetBackup\\\\temp\\\\_vrts_frzn_img_3200\\"
SomeText#/ahol5d72_1_2
SomeText#/p7ol4a1p_1_2
SomeText#Gvadag04SANDsk_Daily
SomeText#/bck_reco_a9ol5765_1_2_827497669';
my $regex = qr/SomeText#(?:(.*?BACKUP) )?(?P<jobFileList>(?(1)[^ ]*|.*$))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}