const regex = /SomeText#(?:(.*?BACKUP) )?(?P<jobFileList>(?(1)[^ ]*|.*$))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('SomeText#(?:(.*?BACKUP) )?(?P<jobFileList>(?(1)[^ ]*|.*$))', 'gm')
const str = `SomeText#"C:\\\\","Shadow Copy Components:\\\\","E:\\\\",""
SomeText#"D:\\\\"
SomeText#"E:\\\\","Shadow Copy Components:\\\\"
SomeText#"SET SNAP_ID=serv.a.x.com_1380312019","BACKUP H:\\\\ USING \\\\\\\\?\\\\GLOBALROOT\\\\Device\\\\HarddiskVolumeShadowCopy47\\\\OPTIONS:ALT_PATH_PREFIX=c:\\\\VERITAS\\\\NetBackup\\\\temp\\\\_vrts_frzn_img_3200\\"
SomeText#"SET SNAP_ID=serv.a.x.com_1380312019","BACKUP Y:\\\\Libs USING \\\\\\\\?\\\\GLOBALROOT\\\\Device\\\\HarddiskVolumeShadowCopy47\\\\OPTIONS:ALT_PATH_PREFIX=c:\\\\VERITAS\\\\NetBackup\\\\temp\\\\_vrts_frzn_img_3200\\"
SomeText#/ahol5d72_1_2
SomeText#/p7ol4a1p_1_2
SomeText#Gvadag04SANDsk_Daily
SomeText#/bck_reco_a9ol5765_1_2_827497669`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}