const regex = /.\n./g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.\\n.', 'g')
const str = `Sentence
Sentence
Sentence
Sentence
Sentence
Sentence
Sentence`;
const subst = `\\`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);