use strict;
my $str = 'Sentence
Sentence
Sentence
Sentence
Sentence
Sentence
Sentence';
my $regex = qr/.\n./p;
my $subst = '\\\\';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";