re = /.\n./
str = 'Sentence
Sentence
Sentence
Sentence
Sentence
Sentence
Sentence'
subst = '\\\\'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result