#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<h([1-6]).*>.*<\/h\1>"
Local $sString = "<h1>Ceci est <u>un test</u></h1>" & @CRLF & _
" <table>" & @CRLF & _
" <tr valign="center">" & @CRLF & _
" <td><h1 style="display:block; font-weight:700; font-size:26;">Niveau H1</h1>" & @CRLF & _
" <h2 style="display:block; font-weight:700; font-size:20;">Niveau H2</h2>" & @CRLF & _
" <h3>Niveau H3</h3></td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td><h4>Niveau H4</h4><h5>Niveau H5</h5><h6>Niveau H6</h6></td>" & @CRLF & _
" </tr>" & @CRLF & _
" </table>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")