import Foundation
let pattern = #"<h([1-6]).*>.*<\/h\1>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<h1>Ceci est <u>un test</u></h1>
<table>
<tr valign="center">
<td><h1 style="display:block; font-weight:700; font-size:26;">Niveau H1</h1>
<h2 style="display:block; font-weight:700; font-size:20;">Niveau H2</h2>
<h3>Niveau H3</h3></td>
</tr>
<tr>
<td><h4>Niveau H4</h4><h5>Niveau H5</h5><h6>Niveau H6</h6></td>
</tr>
</table>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)