$re = '/<h([1-6]).*>.*<\/h\1>/';
$str = '<h1>Ceci est <u>un test</u></h1>
<table>
<tr valign="center">
<td><h1 style="display:block; font-weight:700; font-size:26;">Niveau H1</h1>
<h2 style="display:block; font-weight:700; font-size:20;">Niveau H2</h2>
<h3>Niveau H3</h3></td>
</tr>
<tr>
<td><h4>Niveau H4</h4><h5>Niveau H5</h5><h6>Niveau H6</h6></td>
</tr>
</table>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);