import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<h([1-6]).*>.*<\\/h\\1>";
final String string = "<h1>Ceci est <u>un test</u></h1>\n"
+ " <table>\n"
+ " <tr valign=\"center\">\n"
+ " <td><h1 style=\"display:block; font-weight:700; font-size:26;\">Niveau H1</h1>\n"
+ " <h2 style=\"display:block; font-weight:700; font-size:20;\">Niveau H2</h2>\n"
+ " <h3>Niveau H3</h3></td>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td><h4>Niveau H4</h4><h5>Niveau H5</h5><h6>Niveau H6</h6></td>\n"
+ " </tr>\n"
+ " </table>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}