use strict;
my $str = '<h1>Ceci est <u>un test</u></h1>
<table>
<tr valign="center">
<td><h1 style="display:block; font-weight:700; font-size:26;">Niveau H1</h1>
<h2 style="display:block; font-weight:700; font-size:20;">Niveau H2</h2>
<h3>Niveau H3</h3></td>
</tr>
<tr>
<td><h4>Niveau H4</h4><h5>Niveau H5</h5><h6>Niveau H6</h6></td>
</tr>
</table>';
my $regex = qr/<h([1-6]).*>.*<\/h\1>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}