#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^[0-9]{0,7}(\.[0-9]{1,2}|[0-9]{0,2})$"
Local $sString = ".01" & @CRLF & _
"1" & @CRLF & _
"1.01" & @CRLF & _
"0" & @CRLF & _
"1234567.89" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
".012" & @CRLF & _
"1.098" & @CRLF & _
"123.456"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")