package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^[0-9]{0,7}(\.[0-9]{1,2}|[0-9]{0,2})$`)
var str = `.01
1
1.01
0
1234567.89
.012
1.098
123.456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}