import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-9]{0,7}(\\.[0-9]{1,2}|[0-9]{0,2})$";
final String string = ".01\n"
+ "1\n"
+ "1.01\n"
+ "0\n"
+ "1234567.89\n\n\n"
+ ".012\n"
+ "1.098\n"
+ "123.456";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}