using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\s*Waiting Period)(?:(?:\s{2,})(.*))";
string input = @"Waiting Period 30 days of employment 30 days of employment 30 days of employment
Benefit amount Flat $150,000 Flat $100,000 Flat $60,000
Maximum benefit $150,000 $100,000 $60,000
Contributions Noncontributory Noncontributory Noncontributory
Participation requirement 100.00% 100.00% 100.00%
---
Benefit amount Flat $40,000 Flat $20,000
Maximum benefit $40,000 $20,000
Compulsory coverage Yes Yes
Contributions Noncontributory Noncontributory
Waiting Period 30 days of employment 30 days of employment";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}