$re = '/^(?:\s*Waiting Period)(?:(?:\s{2,})(.*))/m';
$str = 'Waiting Period 30 days of employment 30 days of employment 30 days of employment
Benefit amount Flat $150,000 Flat $100,000 Flat $60,000
Maximum benefit $150,000 $100,000 $60,000
Contributions Noncontributory Noncontributory Noncontributory
Participation requirement 100.00% 100.00% 100.00%
---
Benefit amount Flat $40,000 Flat $20,000
Maximum benefit $40,000 $20,000
Compulsory coverage Yes Yes
Contributions Noncontributory Noncontributory
Waiting Period 30 days of employment 30 days of employment';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);