import Foundation
let pattern = #"^(?:\s*Waiting Period)(?:(?:\s{2,})(.*))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Waiting Period 30 days of employment 30 days of employment 30 days of employment
Benefit amount Flat $150,000 Flat $100,000 Flat $60,000
Maximum benefit $150,000 $100,000 $60,000
Contributions Noncontributory Noncontributory Noncontributory
Participation requirement 100.00% 100.00% 100.00%
---
Benefit amount Flat $40,000 Flat $20,000
Maximum benefit $40,000 $20,000
Compulsory coverage Yes Yes
Contributions Noncontributory Noncontributory
Waiting Period 30 days of employment 30 days of employment
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)