import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\s*Waiting Period)(?:(?:\\s{2,})(.*))";
final String string = "Waiting Period 30 days of employment 30 days of employment 30 days of employment\n"
+ " Benefit amount Flat $150,000 Flat $100,000 Flat $60,000\n"
+ " Maximum benefit $150,000 $100,000 $60,000\n"
+ " Contributions Noncontributory Noncontributory Noncontributory\n"
+ " Participation requirement 100.00% 100.00% 100.00%\n"
+ "---\n"
+ "Benefit amount Flat $40,000 Flat $20,000\n"
+ " Maximum benefit $40,000 $20,000\n"
+ " Compulsory coverage Yes Yes\n"
+ " Contributions Noncontributory Noncontributory\n"
+ "Waiting Period 30 days of employment 30 days of employment";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}