# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<img\b[^>]*\ssrc="(?!cid:)[^>]*>//gm;t' <<< "Remove this tag: <img src=\"path/to/image\">.
Also remove this tag: <img src=\"path/to/second/image\">.
But don't touch this <img src=\"cid:1259asdhasi\">."