const regex = /<img\b[^>]*\ssrc="(?!cid:)[^>]*>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img\\b[^>]*\\ssrc="(?!cid:)[^>]*>', 'gm')
const str = `Remove this tag: <img src="path/to/image">.
Also remove this tag: <img src="path/to/second/image">.
But don't touch this <img src="cid:1259asdhasi">.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);