re = /<img\b[^>]*\ssrc="(?!cid:)[^>]*>/m
str = 'Remove this tag: <img src="path/to/image">.
Also remove this tag: <img src="path/to/second/image">.
But don\'t touch this <img src="cid:1259asdhasi">.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result