#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<img\b[^>]*\ssrc="(?!cid:)[^>]*>"
Local $sString = "Remove this tag: <img src="path/to/image">. " & @CRLF & _
"Also remove this tag: <img src="path/to/second/image">. " & @CRLF & _
"But don't touch this <img src="cid:1259asdhasi">."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)