using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img\b[^>]*\ssrc=""(?!cid:)[^>]*>";
string substitution = @"";
string input = @"Remove this tag: <img src=""path/to/image"">.
Also remove this tag: <img src=""path/to/second/image"">.
But don't touch this <img src=""cid:1259asdhasi"">.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}