const regex = /^(\s*)(http\S+)(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\s*)(http\\S+)(.*)$', 'gm')
const str = `sublimetext macro
https://sublime-text-unofficial-documentation.readthedocs.io/en/stable/core/commands.html
https://docs.sublimetext.io/reference/commands.html#commands
https://docs.sublimetext.io/guide/extensibility/snippets.html#substitutions
sublime text macro replace text`;
const subst = `$1* <$2>$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);