use strict;
my $str = 'sublimetext macro
https://sublime-text-unofficial-documentation.readthedocs.io/en/stable/core/commands.html
https://docs.sublimetext.io/reference/commands.html#commands
https://docs.sublimetext.io/guide/extensibility/snippets.html#substitutions
sublime text macro replace text';
my $regex = qr/^(\s*)(http\S+)(.*)$/mp;
my $subst = '$1* <$2>$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";