re = /^(\s*)(http\S+)(.*)$/m
str = 'sublimetext macro
https://sublime-text-unofficial-documentation.readthedocs.io/en/stable/core/commands.html
https://docs.sublimetext.io/reference/commands.html#commands
https://docs.sublimetext.io/guide/extensibility/snippets.html#substitutions
sublime text macro replace text'
subst = '$1* <$2>$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result