#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([1-9]{1,3}.){1,4}\/([1-9]{1,2})"
Local $sString = "outlook.com" & @CRLF & _
"spf-a.outlook.com" & @CRLF & _
"spf-b.outlook.com" & @CRLF & _
"157.55.9.128/25" & @CRLF & _
"spf.protection.outlook.com" & @CRLF & _
"spf-a.hotmail.com" & @CRLF & _
"_spf-ssg-b.microsoft.com" & @CRLF & _
"_spf-ssg-c.microsoft.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")