# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([1-9]{1,3}.){1,4}\/([1-9]{1,2})"
test_str = ("outlook.com\n"
"spf-a.outlook.com\n"
"spf-b.outlook.com\n"
"157.55.9.128/25\n"
"spf.protection.outlook.com\n"
"spf-a.hotmail.com\n"
"_spf-ssg-b.microsoft.com\n"
"_spf-ssg-c.microsoft.com")
matches = re.search(regex, test_str, re.MULTILINE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.