const regex = /([1-9]{1,3}.){1,4}\/([1-9]{1,2})/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([1-9]{1,3}.){1,4}\\\/([1-9]{1,2})', 'm')
const str = `outlook.com
spf-a.outlook.com
spf-b.outlook.com
157.55.9.128/25
spf.protection.outlook.com
spf-a.hotmail.com
_spf-ssg-b.microsoft.com
_spf-ssg-c.microsoft.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}