re = /([1-9]{1,3}.){1,4}\/([1-9]{1,2})/m
str = 'outlook.com
spf-a.outlook.com
spf-b.outlook.com
157.55.9.128/25
spf.protection.outlook.com
spf-a.hotmail.com
_spf-ssg-b.microsoft.com
_spf-ssg-c.microsoft.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end