import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([1-9]{1,3}.){1,4}\\/([1-9]{1,2})";
final String string = "outlook.com\n"
+ "spf-a.outlook.com\n"
+ "spf-b.outlook.com\n"
+ "157.55.9.128/25\n"
+ "spf.protection.outlook.com\n"
+ "spf-a.hotmail.com\n"
+ "_spf-ssg-b.microsoft.com\n"
+ "_spf-ssg-c.microsoft.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}