# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d+(?=\.\d{5}\s)/8/gm;t' <<< "{1 0.78987 23.786}"