import re
regex = re.compile(r"\d+(?=\.\d{5}\s)", flags=re.MULTILINE)
test_str = "{1 0.78987 23.786}"
subst = "8"
result = regex.sub(subst, test_str)
if result:
print(result)