$re = '/\d+(?=\.\d{5}\s)/m';
$str = '{1 0.78987 23.786}';
$subst = "8";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;