import Foundation
let pattern = #"\d+(?=\.\d{5}\s)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"{1 0.78987 23.786}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"8"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)