using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^first(?:\s+(?ufsuj33004\b)\w+)*\s+last$";
string input = @"First one two word last
first three ufsuj33004 four last
first five swordfish six seven last";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}