// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^first(?:\s+(?ufsuj33004\b)\w+)*\s+last$").unwrap();
let string = "First one two word last
first three ufsuj33004 four last
first five swordfish six seven last";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}