re = /^first(?:\s+(?ufsuj33004\b)\w+)*\s+last$/im
str = 'First one two word last
first three ufsuj33004 four last
first five swordfish six seven last'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end