$re = '/^first(?:\s+(?ufsuj33004\b)\w+)*\s+last$/im';
$str = 'First one two word last
first three ufsuj33004 four last
first five swordfish six seven last';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);