const regex = /^first(?:\s+(?ufsuj33004\b)\w+)*\s+last$/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^first(?:\\s+(?ufsuj33004\\b)\\w+)*\\s+last$', 'igm')
const str = `First one two word last
first three ufsuj33004 four last
first five swordfish six seven last`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}