using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Za-z]+(?= ?:\[\(h\d+\){h\d+}])";
string input = @"Taxi:[(h19){h12}], HeavyTruck :[(h19){h12}]
Taxi:[(h19){h12}], HeavyTruck :[(h19){h12}
Taxi:[(h19){h12}, HeavyTruck :[(h19){h12}]
Taxi:[(h19){12}], HeavyTruck [(h19){h12}]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}