import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Za-z]+(?= ?:\\[\\(h\\d+\\)\\{h\\d+\\}])";
final String string = "Taxi:[(h19){h12}], HeavyTruck :[(h19){h12}]\n\n\n\n"
+ "Taxi:[(h19){h12}], HeavyTruck :[(h19){h12}\n"
+ "Taxi:[(h19){h12}, HeavyTruck :[(h19){h12}]\n"
+ "Taxi:[(h19){12}], HeavyTruck [(h19){h12}]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}