re = /[A-Za-z]+(?= ?:\[\(h\d+\){h\d+}])/
str = 'Taxi:[(h19){h12}], HeavyTruck :[(h19){h12}]
Taxi:[(h19){h12}], HeavyTruck :[(h19){h12}
Taxi:[(h19){h12}, HeavyTruck :[(h19){h12}]
Taxi:[(h19){12}], HeavyTruck [(h19){h12}]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end