$re = '/[A-Za-z]+(?= ?:\[\(h\d+\){h\d+}])/';
$str = 'Taxi:[(h19){h12}], HeavyTruck :[(h19){h12}]
Taxi:[(h19){h12}], HeavyTruck :[(h19){h12}
Taxi:[(h19){h12}, HeavyTruck :[(h19){h12}]
Taxi:[(h19){12}], HeavyTruck [(h19){h12}]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);